Thoughts from Dan Miser RSS 2.0
# Sunday, 01 December 2013
Trying to follow the directions to host your own Nuget server, I ran into a couple small problems when trying to deploy it to a Virtual Application within an Azure WebSite. I was able to successfully deploy this inside the Virtual Application using my previously posted directions. But I still found these issues:

1. The URL was actually requiring a second nuget appended to the end (i.e. http://www.mydomain.com/nuget/nuget/).
2. When accessing the required URL above, I received this error:
This collection already contains an address with scheme http. There can be at most one address per scheme in this collection. 
If your service is being hosted in IIS you can fix the problem by setting 'system.serviceModel/serviceHostingEnvironment/multipleSiteBindingsEnabled' to true 
or specifying 'system.serviceModel/serviceHostingEnvironment/baseAddressPrefixFilters'.

The solution was to update the web.config to add this attribute to the element that was already there.

<serviceHostingEnvironment multipleSiteBindingsEnabled="true" aspNetCompatibilityEnabled="true"/>


Sunday, 01 December 2013 21:51:33 (GMT Standard Time, UTC+00:00)  #    Comments [0] -
.NET | ASP.NET
Comments are closed.
Navigation
Archive
<2017 December>
SunMonTueWedThuFriSat
262728293012
3456789
10111213141516
17181920212223
24252627282930
31123456
Blogroll
About the author/Disclaimer

Disclaimer
The opinions expressed herein are my own personal opinions and do not represent my employer's view in any way.

© Copyright 2017
Dan Miser
Sign In
Statistics
Total Posts: 388
This Year: 0
This Month: 0
This Week: 0
Comments: 630
Themes
Pick a theme:
All Content © 2017, Dan Miser
DasBlog theme 'Business' created by Christoph De Baene (delarou)